La Lanterne Rouge

La Lanterne Rouge

Warning: Geek Inside

Publié le par Nanawel
Publié dans : #linux | #flash | #vidéo

Petit billet pour garder une trace de la cause... et de la solution.

Depuis quelques semaines sur mon PC du boulot (sous Archlinux), il arrivait qu'à partir d'un point dans la journée plus aucune vidéo ne veuille se lire. Ce qui concernait :

  • les vidéos HTML5 de Youtube (tous navigateurs confondus)
  • les vidéos sur Facebook et Twitter (idem)
  • les vidéos lues sur VLC (là y'avait l'image, mais pas le son)
  • etc.

Dans les deux premiers cas, les quelques premières frames s'affichaient, et le lecteur arrivait parfois péniblement à aller jusqu'à 00:01, puis plus rien, sauf un message sur Youtube indiquant que si la lecture échouait il fallait redémarrer l'appareil (ouais mais non, je vais pas rebooter mon PC pour une vidéo). Fermer et relancer les navigateurs ne suffisait pas.

Puis en lançant un peu par hasard un petit

$ ps aux | grep flash

J'ai remarqué un process de Firefox mentionnant Flash :

user 28289  5.2  0.5 1039452 90724 tty2    SLl+ 11:14   4:39 /usr/lib/firefox/plugin-container /usr/lib/mozilla/plugins/libflashplayer.so -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appdir /usr/lib/firefox/browser 8592 true plugin

Tiens, et si je le killais méchamment ?

Et hop, les vidéos remarchent ! (bon, mais il faut recharger les pages qui utilisaient Flash sur Firefox, ce qui se réduisait chez moi à Subsonic).

Commenter cet article